Lenovo X300 still freezing

My new Lenovo X300 laptop, freshly formatted and configured with Windows XP SP3 and all the latest drivers from the Lenovo website, is freezing up on me around once every two days on average. 

At first I thought I had fixed this with the latest bios update but just got three more freezes since. I also thought it might be due to overheating as it froze twice on me while sitting on my blanket, but it also hung on me on my desk at work (underside was quite cool at the time). 

Not sure what the problem is. Googling the issue seems to suggest a lot of other owners having similar issues and no statements from Lenovo. I'm not keen on sending it in for warranty repair at this time as I'm sure they'll just send it back saying they could not reproduce the problem and three weeks later I'll be in the same boat.

I'll post an update here if I ever find a solution. Or if you're an X300 owner and have the same issue, please leave a comment below.

UPDATE: 2009-05-21
Installed Windows 7 RC (Build 7100) and so far so good. No crashes yet (although too soon  to tell if problem has been fixed). I did notice once however that the laptop froze for about 5 seconds, and I thought it was dead, but it managed to recover itself this time. Upon recovery, the wireless adapter was down, i.e. connection dropped and could not detect any networks. Clicking on 'Help me fix this problem' in the Windows 7 popup restored the connection. Whilst still not good, this sure beats having to cold reboot your computer and hope that the files you were working on didn't get corrupted and zeroed out.


Comments

  1. what version of bios do you use? I've never had this problem with mine. Although I upgraded the bios to the latest version after I bought it.

    ReplyDelete
  2. I'm running 1.9 or 1.09, but I see version 1.10 has just been released a few days ago. I'll be trying this out to see if it fixes the issue. I suspect it's a power management problem as it happens a lot more frequently when running on battery. Perhaps CPU is not getting enough juice... I should also do a RAM mem test to make sure everything's in order.

    ReplyDelete
  3. My X300 also randomly freezes (XP Pro). It also locked up with windows7RC1. Also loaded the lastest bios and no luck. Don't want to deal with the hassle of calling it in... they already gave me a hard time just to get the restore CD's. Can't imagine how they would handle this issue.

    ReplyDelete

Post a Comment

Popular posts from this blog

Wkhtmltopdf font and sizing issues

Import Google Contacts to Nokia PC Suite

Can't delete last blank page from Word