Installing vmware-tools on Debian/Ubuntu

Recently I tried installing the vmware-tools package on a new Ubuntu 13.04 and also a new Debian 7 VMWare Fusion virtual machine. In both cases, the vmware-tools installed gave an error along the following lines:

  • Searching for a valid kernel header path...
  • The path "" is not a valid path to the 3.2.0-4-amd64 kernel headers.
  • Would you like to change it? [yes] 
The solution to this is to install the necessary kernel headers and re-run the vmware-tools install script.

  • sudo apt-get update
  • sudo apt-get install build-essential
  • sudo apt-get install linux-headers-$(uname -r)


Comments

  1. Thank you very much for this information - it worked.

    ReplyDelete
  2. Awesome, worked perfectly. Thank you!!

    ReplyDelete
  3. THANK YOU SO MUCH

    ReplyDelete
  4. Great... Excellent sharing.. This is very helpful for beginners. Read that provide me more enthusiastic. This helps me get a more knowledge about this topic. Thanks for this.hunt aws experienced jobs in hyderabad

    ReplyDelete
  5. Thank you ! ça marche bien :)

    ReplyDelete
  6. This comment has been removed by the author.

    ReplyDelete

Post a Comment

Popular posts from this blog

Wkhtmltopdf font and sizing issues

Import Google Contacts to Nokia PC Suite

Can't delete last blank page from Word